The package could not be installed. PCLZIP_ERR_BAD_FORMAT

I was updating a WordPress site from wordpress core, themes and plugins and unfortunately while updating plugin in the last part I got this error message “The package could not be installed. PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature”, so I begin digging into wordpress site, wordpress forum, blog and yayy I found the answer and I want to share you how to get rid this error.


The error is due to the low server space or the server space is full or disk space is full, so all you need to do is upgrade your hosting plan or delete unwanted files or if ever you have a back-up files of your site, move your back-up files from your server to your computer, sometimes we store our back-up file in the server.

Getting same error installing theme in localhost?


Please be sure you’re uploaded the theme, plugin in correct path.

If you have other solution it would be great if you share it below.

by Ryan Sutana

  • Relocated some backups to create some space – worked like a charm, thanks!

  • Anke Arnold

    Woohoo, worked! Thanks a lot for your explanation – it saved me lots of time!

    • You’re welcome, glad it helps